Vokabeltrainer-Hilfe: Vokabeldatei: Einstellungen: Sprachen

Das Register Sprachen

In diesem Register können Sie mehrere zentrale Einstellungen zur Vokabeldatei ablesen bzw. ändern wie z.B. die verwendeten Sprachen und Sonderzeichen.

Hinweis zur Eingabe von Sprachen mit besonderen Zeichensätzen:

Wenn Sie Vokabeln in nicht-'westlichen' Sprachen (Türkisch, Russisch, Polnisch, Griechisch, Ungarisch, Rumänisch, Tschechisch, Hebräisch etc.) eingeben möchten, lesen Sie insbesondere den Abschnitt "Haupt-Skript einstellen und Tastaturlayout einrichten" weiter unten auf dieser Hilfeseite.
Wenn Sie chinesische, japanische oder koreanische Vokabeln eingeben möchten, lesen Sie insbesondere den Abschnitt "IME" weiter unten auf dieser Hilfeseite.

Sprachen

Stellen Sie hier die von der Vokabeldatei verwendeten Sprachen ein (z.B. Englisch und Deutsch). Jede Vokabeldatei besteht aus genau zwei Sprachen. Wenn Sie in eine Vokabeldatei keine Vokabeln, sondern z.B. Allgemeinbildungsfragen eingeben möchten, können die 'Sprachen' natürlich auch Frage und Antwort heißen - oder z.B. Land und Hauptstadt bei einer Vokabeldatei, mit der Sie die Hauptstädte der Welt trainieren.

Wenn Sie eine neue Vokabeldatei erstellen, bestimmt der erste Sprachname (z.B. Englisch) meistens auch den Sprachordner, in dem die Vokabeldatei gespeichert wird. Wenn die Vokabeldatei in einem anderen Sprachordner gespeichert werden soll, können Sie den Namen des Sprachordners jedoch auch direkt oben im Fenster ändern: z.B. könnten Sie für die Hauptstadt-Lerndatei mit den 'Sprachen' Land und Hauptstadt den Sprachordner Geographie einstellen; für eine Datei mit den Sprachen Präsident und Regierungsjahr könnten Sie den Sprachordner Geschichte einstellen.

Haupt-Schriftstil

Für jede Sprache können Sie einen Haupt-Schriftstil festlegen: Wenn Sie bei der Vokabeleingabe einen neuen Vokabeleintrag eingeben, stellt das Programm dafür zunächst den Haupt-Schriftstil der jeweiligen Sprache ein. Sie können während der Eingabe einer Vokabel natürlich jederzeit auf einen anderen Schriftstil umschalten; es ist jedoch zeitsparender, wenn Sie als Haupt-Schriftstil gleich denjenigen Schriftstil einstellen, den Sie bei der Vokabeleingabe am häufigsten benötigen. Im Normalfall wird das der Schriftstil Standard sein.

Bei Sprachen, die einen sehr speziellen Schriftstil benötigen (z.B. Althebräisch, das nur mit Spezialzeichensätzen eingegeben werden kann), kann hier die Einstellung eines anderen Schriftstils notwendig werden.

Hinweis: Verwenden Sie das Menü Bearbeiten / Schriftstile, um die Schriftstile einer Vokabeldatei zu bearbeiten und neue Schriftstile hinzuzufügen. Alle Schriftstile, die Sie dort für eine Vokabeldatei einstellen, können hier als Haupt-Schriftstil ausgewählt werden.

Zur Bedeutung von Skripts (Codepages)

Ein normaler Zeichensatz enthält 256 Zeichen. Davon wird die erste Hälfte (Zeichen Nr. 0-127) insbesondere für die lateinischen Buchstaben ( ABCDE...Z und abcde...z), für Zahlen (0123...9) und Satzzeichen (,.;:/!"? etc.) verwendet. Die zweite Hälfte (Zeichen Nr. 128-255) wird dagegen vor allem für Sonderzeichen verwendet (z.B. das deutsche äöüßÄÖÜ und Zeichen mit Akzenten wie áéíóú).

Da die Sprachen der Welt zusammen jedoch weit mehr als 128 Sonderzeichen haben (z.B. haben Griechisch, Hebräisch und Russisch alle ein ganz eigenes Alphabet!), besteht unter Windows die Möglichkeit, für die zweite Hälfte des Zeichensatzes ein so genanntes Skript auszuwählen:

Wählt man z.B. das Skript Kyrillisch, so enthält der Zeichensatz in der ersten Hälfte (0-127) wie immer die lateinischen Buchstaben, in der zweiten (128-255) aber alle kyrillischen Buchstaben. Bei einer solchen Einstellung lassen sich dann (mit einem ganz "normalen" Zeichensatz wie "Arial" oder "Times New Roman") russische Vokabeln in kyrillischer Schrift eingeben.
Schaltet man nun auf das Skript Griechisch oder Hebräisch um, so kann man damit keine kyrillischen Buchstaben mehr tippen, dafür aber griechische bzw. hebräische Buchstaben (128-255) und natürlich nach wie vor die lateinischen Buchstaben (0-127).
  Hinweis: Allerdings können die im Alt griechischen verwendeten Akzente und Spiritus bzw. die im Althebräischen verwendeten Vokalzeichen nicht dargestellt werden. Daher eignet sich das griechische bzw. hebräische Skript nur zur Eingabe neugriechischer bzw. (unvokalisierter) neuhebräischer Vokabeln. Für altgriechische bzw. althebräische Vokabeln empfiehlt sich dagegen ein spezieller Zeichensatz wie Bwgrkl bzw. Bwhebb.
Das Skript Western fasst alle Sonderzeichen zusammen, die von den Sprachen der 'westlichen' Welt benötigt werden. Diese Sprachen basieren auf dem lateinischen Alphabet (0-127), verwenden aber jeweils einige zusätzliche Zeichen (128-255): Deutsch äAöÖüÜß, Französisch çÇëËïÏœŒ, Holländisch çÇëËïÏ, Portugiesisch ãÃçÇõÕ, Spanisch ñÑ¡¿ etc.
  Hinweis: Spezielle Zeichensätze wie Bwgrkl (für Altgriechisch) bzw. Bwhebb (für Althebräisch) verwenden technisch zwar das Skript "Western", stellen dort aber völlig andere Zeichen dar als z.B. der Zeichensatz Arial - auch in der ersten Hälfte des Zeichensatzes (Zeichen-Nr. 0-127).
Das Skript Mitteleuropäisch enthält die Sonderzeichen, die z.B. für Polnisch, Rumänisch, Slowakisch, Tschechisch, Türkisch und Ungarisch benötigt werden.
Einen Sonderfall stellen die Skripts für Chinesisch, Japanisch und Koreanisch dar, da diese drei Sprachen kein Alphabet verwenden, sondern jeweils viele tausend Schriftzeichen. Der Computer benötigt daher zwei Zeichen (128 * 128 = 16.384 Kombinationsmöglichkeiten), um z.B. ein chinesisches Schriftzeichen zu speichern. (Z.B. werden die beiden Zeichen ÖÓ zu dem chinesischen Schriftzeichen für 'zhong' = Uhr kombiniert; die Zeichen ÄÃ ergeben das Schriftzeichen für 'na' = nehmen, die Zeichen Êé das Schriftzeichen für 'shu' = Buch ).

Hinweis: Heutige Bestrebungen gehen dahin, den Computer generell so umzustellen, dass in allen Texten zwei Zeichen (Bytes) für jeden Buchstaben gespeichert werden: Damit könnte man sich das Umschalten zwischen verschiedenen Skripts ersparen, da in den 256 * 256 = 65.536 Kombinationsmöglichkeiten alle in den Sprachen der Erde verwendeten Buchstaben und Schriftzeichen untergebracht werden können. Dieses Verfahren nennt man Unicode. Der Vokabeltrainer verwendet jedoch kein Unicode, da die dazu notwendigen Voraussetzungen nicht auf allen Windows-Systemen gegeben sind.

Haupt-Skript einstellen und Tastaturlayout einrichten

Sie können für jede Sprache deren Haupt-Skript einstellen. Für die gängigsten Sprachen stellt der Vokabeltrainer das Haupt-Skript automatisch für Sie ein, sobald Sie oben in diesem Register den Sprachnamen eingeben: Für die 'westlichen' Sprachen Deutsch, Englisch, Französisch, Italienisch, Spanisch usw. wird das Haupt-Skript Western verwendet; für eine Reihe mitteleuropäischer Sprachen Mitteleuropäisch ; fürs Russische Kyrillisch usw.

Um Vokabeln in Sprachen einzugeben, die ein nicht-'westliches' Skript verwenden (z.B. das Skript Arabisch, Griechisch, Hebräisch, Kyrillisch, Mitteleuropäisch oder Türkisch), müssen Sie außerdem ein entsprechendes Tastaturlayout einstellen:

Rufen Sie in der Windows-Leiste das Menü Start / Einstellungen / Systemsteuerung: "Tastatur", Register "Sprache", Schaltfläche "Hinzufügen" auf (bzw. Start / Einstellungen / Systemsteuerung: "Regions- und Sprachoptionen", Register "Sprache", Schaltfläche "Details", Schaltfläche "Hinzufügen").
Fügen Sie das passende Eingabegebietsschema / Tastaturlayout hinzu (je nach der Sprache, die Sie eingeben möchten) und schließen Sie die Windows-Einstellungsfenster wieder mit OK.
Bei der Eingabe von Vokabeln können Sie jetzt mit der Tastenkombination Strg + Umschalttaste bzw. Linke Alt-Taste + Umschalttaste zwischen dem gewohnten 'westlichen' und z.B. dem kyrillischen Tastaturlayout umschalten. In der Windows-Leiste sehen Sie, welches Tastaturlayout gerade aktiv ist. So lassen sich mit Ihrer Tastatur wechselweise kyrillische und lateinische Zeichen erzeugen.

Die Einstellung des richtigen Skripts sorgt also dafür, dass der Computer die gewünschten Zeichen (z.B. das kyrillische oder das griechische Alphabet) überhaupt darstellen kann. Das Tastaturlayout benötigen Sie zusätzlich, um diese Zeichen auch mit der Tastatur eingeben zu können.

Sonderzeichen

In diesem Feld werden die Sonderzeichen der beiden Sprachen verzeichnet. Auch Sprachen, die grundsätzlich ein 'westliches' Skript verwenden, benötigen zum Teil Sonderzeichen, die auf der deutschen Tastatur nicht ohne weiteres erzeugt werden können - z.B. çÇëËïÏœŒ im Französischen und ñÑ¡¿ im Spanischen. Für die gängigsten Sprachen stellt der Vokabeltrainer die benötigten Sonderzeichen automatisch für Sie ein, sobald Sie oben in diesem Register den Sprachnamen eingeben.

  Hinweis: Die Zeichen áÁéÉíÍóÓúÚýÝ, àÀèÈìÌòÒùÙ, âÂêÊîÎôÔûÛ müssen nicht als Sonderzeichen angegeben werden, da sie auch mit der deutschen Tastatur erzeugt werden können: Drücken Sie dazu zuerst die Akzent-Taste (´ bzw. ` bzw. ^) und anschließend einen der Vokale aAeEiIoOuU.

Um selbst Sonderzeichen in diese Zeile einzufügen, verwenden Sie z.B. in Microsoft Word die Funktion "Einfügen / Sonderzeichen" (bzw. "Einfügen / Symbol"), markieren Sie die in Word erzeugten Zeichen mit der Maus, drücken Sie die Tastenkombinationen Strg + C (kopieren), setzen Sie den Cursor in das Sonderzeichen-Eingabefeld des Vokabeltrainers und drücken Sie Strg + V , um die Zeichen dort einzufügen.

Der Vokabeltrainer zeigt die hier eingestellten Sonderzeichen bei der Vokabeleingabe und beim Vokabeltraining (Trainingstyp Trainieren und Kreuzworträtsel) an, also überall, wo Sie selbst Vokabeln tippen müssen. Sie können dann mit einem Mausklick auf die Sonderzeichenleiste ein Sonderzeichen in die Eingabezeile einfügen. Statt des Mausklicks können Sie auch die Tastenkombination Strg + F1 verwenden, um das erste Sonderzeichen der Sonderzeichenleiste einzufügen; Strg + F2 , um das zweite Sonderzeichen einzufügen usw.

Hinweis: Für die meisten Sprachen reicht es, die Kleinbuchstaben in die Sonderzeichenleiste einzugeben, da Sie beim Vokabeltraining und Vokabeleingabe große Sonderzeichen erzeugen können, indem Sie die Shift-Taste gedrückt halten und dann mit der Maus auf die Sonderzeichenleiste klicken (z.B. wird durch Shift + Mausklick auf das Sonderzeichen ç ein Ç in die Eingabezeile eingefügt).

IME (für Chinesisch, Japanisch und Koreanisch)

Wenn Sie Vokabeln in chinesischen, japanisch oder koreanischen Schriftzeichen eingeben möchten, können Sie dafür unter Windows 2000 und Windows XP den "Input Method Editor" (IME) von Windows verwenden. In diesem Fall sollten Sie im Vokabeltrainer die IME -Einstellung auf Aktiviert stellen, um die IME-Unterstützung des Vokabeltrainers zu aktivieren. In allen anderen Fällen stellen Sie die Einstellung bitte auf Deaktiviert.

Um Chinesisch, Japanisch und Koreanisch einzugeben, verfahren Sie folgendermaßen:

Aktivieren Sie IME unter Windows. Verwenden Sie dazu Start - Einstellungen - Systemsteuerung - Regions- und Sprachoptionen - Register "Sprachen". Aktivieren Sie die Option "Dateien für ostasiatische Sprachen installieren" und richten Sie mit der Schaltfläche "Details" / "Hinzufügen" ein Eingabeschema für die gewünschte Sprache ein.
Stellen Sie im Vokabeltrainer im Register Sprachen das Haupt-Skript (s.o.) auf die gewünschte Sprache (Chinesisch, Japanisch oder Koreanisch) und wählen Sie IME (Chin. / Jap. / Kor.) aktiviert. Wenn Sie weiter unten das Skript der Vokabeltabelle ebenfalls auf Chinesisch, Japanisch bzw. Koreanisch stellen, werden die Schriftzeichen auch in der Vokabeltabelle (Menü Bearbeiten / Vokabelliste, Register Tabelle) richtig angezeigt.
Bei der Vokabeleingabe (Menü Bearbeiten / Vokabelliste, Register Eingabe) können Sie jetzt in der Windows-Leiste mit der Tastenkombination Strg + Umschalttaste bzw. Linke Alt-Taste + Umschalttaste auf das jeweils passende Eingabeschema (CH, JP oder KO) umschalten und die Schriftzeichen mit IME eingeben.
 

Die Aktualisierung der Vorschau (Menü Bearbeiten / Vokabelliste, Register Eingabe, links die Vorschau-Optionen aktivieren) erfolgt bei aktivierter IME-Unterstützung erst, wenn Sie den Cursor in eine andere Eingabezeile setzen, da sonst (d.h. bei einer ständigen Aktualisierung) die Eingabe mit IME gestört werden würde. Mit der Taste s-adf/druck können Sie jedoch eine Aktualisierung der Vorschau erzwingen, auch ohne in eine andere Eingabezeile zu wechseln.

Textausrichtung

Diese Einstellung ist für Sprachen gedacht, die von rechts nach links geschrieben werden (z.B. Hebräisch und Arabisch). Für alle anderen Sprachen sollten Sie die Textausrichtung auf Normal stellen.

Wenn Sie die Textausrichtung auf Gespiegelt stellen, wird die in den Optionen festgelegte Textausrichtung für diese Sprachen umgekehrt. Wenn Sie z.B. im Menü Einstellungen / Optionen, Register Anzeige die Ausrichtung der Frage/Antwort auf linksbündig gestellt haben, werden die hebräischen bzw. arabischen Vokabeln dieser Vokabeldatei rechtsbündig dargestellt (die Options-Einstellung rechtsbündig wird also in linksbündig umgekehrt).

Die Vokabeln aller anderen Vokabeldateien (deren Textausrichtung auf Normal gestellt ist) werden natürlich weiterhin linksbündig dargestellt, wie es in den Optionen festgelegt ist. Auf diese Weise wird Ihnen erspart, ständig die Einstellungen in den Optionen ändern zu müssen, je nachdem, ob Sie gerade eine hebräische oder eine englische Vokabeldatei geladen haben.

Spracherkenner

Geben Sie hier an, ob der Spracherkenner für diese Sprache verwendet werden oder deaktiviert werden soll. Bitte beachten Sie, dass Sie den Spracherkenner in einer eigenen Vokabeldatei nur dann nutzen können, wenn Sie zu jeder Vokabel Phonemfolgen eingeben.

Wenn Sie den Spracherkenner deaktivieren, wird bei der Auswahl des Trainingstyps im Register Lerninhalt die Option Spracherkenner gar nicht erst angezeigt. Wenn der Spracherkenner dagegen aktiviert ist, wird die Option angezeigt, so dass der Anwender der Vokabeldatei immer noch entscheiden kann, ob er die Spracherkennung in dieser Lektion tatsächlich einsetzen möchte oder nicht.

Skript der Vokabeltabelle

Diese Einstellung wird normalerweise automatisch vom Vokabeltrainer vorgenommen, sobald Sie oben in diesem Register die Sprach namen eingeben. In bestimmten Fällen kann es jedoch nötig sein, die Einstellung manuell abzuändern.

Während Sie unterschiedliche Haupt-Skripts für die beiden Sprachen der Vokabeldatei einstellen können, kann die Vokabeltabelle (Menü Bearbeiten / Vokabelliste und Kapitel, Register Tabelle) nur in einem einzigen Skript angezeigt werden. Es ist also möglich, z.B. eine Spalte dieser Tabelle in einem kyrillischen und die andere in einem griechischen Skript darzustellen. Daher muss an dieser Stelle festgelegt werden, welches Skript für die Vokabeltabelle verwendet werden soll. In den meisten Fällen ist das identisch mit dem Haupt-Skript der ersten Sprache (z.B. Kyrillisch für eine Vokabeldatei mit den Sprachen Russisch und Deutsch).

Ein Ausnahmefall ist z.B. die Verwendung der altgriechischen und althebräischen Zeichensätze SGreek, SHebrew, BwGrkl und BwHebb: Hier muss als Haupt-Skript für beide Sprachen Western (!) eingestellt werden (s.o.), als Skript für die Vokabeltabelle jedoch Hebräisch bzw. Griechisch.

Schriftstil-Voreinstellungen

Hinweis: Diese Einstellungsmöglichkeit im Register Sprachen ist nur sichtbar, wenn Sie das Menü Vokabeldatei / Neu aufrufen, um eine neue Vokabeldatei anzulegen. Sie ist nicht sichtbar, wenn Sie das Menü Bearbeiten / Einstellungen zu einer bereits bestehenden Vokabeldatei aufrufen.

Schriftstile bestimmen darüber, wie der Vokabeltext in Ihrer Vokabeldatei dargestellt wird (ein Schriftstil könnte z.B. so eingestellt sein: "Zeichensatz Arial, Schriftgröße 12 Punkt, Stilmerkmal kursiv, Farbe grün"). Der Vokabeltrainer speichert zu jeder Vokabeldatei die Informationen über alle Schriftstile, die in dieser Vokabeldatei verwendet werden. Mit dem Menü Bearbeiten / Schriftstile können die Schriftstile einer Vokabeldatei verändert werden.

Wenn Sie mehrere ähnliche Vokabeldateien erstellen möchten, wäre es unsinnig, jedes Mal von Neuem die benötigten Schriftstile einstellen zu müssen. Daher bietet das Menü Bearbeiten / Schriftstile, Register Datei Ihnen die Möglichkeit, die Schriftstil-Einstellungen einer bestehenden Vokabeldatei abzuspeichern (z.B. könnten Sie unter dem Namen "Englisch" Ihre bevorzugten Schriftstil-Einstellungen für englische Vokabeldateien speichern). Wenn Sie nun mit dem Menü Vokabeldatei / Neu eine neue Vokabeldatei erstellen, können Sie im Auswahlfeld Schriftstil-Voreinstellungen diese zuvor abgespeicherten Schriftstil-Einstellungen in die neue Vokabeldatei übernehmen.

Falls Sie die so übernommenen Schriftstil-Einstellungen später abändern wollen, können Sie das natürlich jederzeit mit dem Menü Bearbeiten / Schriftstile tun.

Experten-Hinweis: Die Dateien, in denen die Schriftstil-Voreinstellungen gespeichert sind, befinden sich im Unterordner ...\Data\Sty\ unter den mitgelieferten, öffentlichen oder persönlichen Dateien (je nachdem, ob sie allen Anwendern oder nur Ihnen zugänglich sind). Sie haben die Dateiendung .sty.

Index zur Verwendung der Vokabeldatei als Wörterbuch

Hinweis: Diese Steuerelemente im Register Sprachen sind nur sichtbar, wenn Sie das Menü Bearbeiten / Einstellungen nach dem Öffnen einer bereits bestehenden Vokabeldatei aufrufen. Sie sind nicht sichtbar, wenn Sie mit dem Menü Vokabeldatei / Neu eine neue Vokabeldatei erstellen.

Zur Bedeutung von Indizes: Sie können jede beliebige (mitgelieferte, aus dem Internet geladene oder selbst eingegebene) Vokabeldatei mit Hilfe der Funktion Extras / Wörterbuch wie ein Wörterbuch verwenden, also die Vokabeln darin alphabetisch durchblättern. Dazu muss der Vokabeltrainer einen alphabetischen Index aller in der Vokabeldatei enthaltenen Vokabeln erstellen.

Im Normalfall registriert die Wörterbuch-Funktion automatisch, ob der Index zu einer Vokabeldatei erstellt bzw. (nach der Veränderung oder Ergänzung von Vokabeln) aktualisiert werden muss. Falls Sie die Erstellung bzw. Aktualisierung jedoch von Hand veranlassen möchten, können Sie auf die Schaltfläche Index neu erstellen klicken. Der Vokabeltrainer zeigt Ihnen außerdem automatisch an, ob bereits ein Index zu dieser Vokabeldatei vorhanden ist und ob er aktuell ist.

Experten-Hinweis: Die Indizes der mitgelieferten und öffentlichen (also allen Anwendern zugänglichen) Vokabeldateien befinden sich im Ordner ...\Data\Idx\ unter den öffentlichen Dateien; die Indizes der privaten (nur Ihnen zugänglichen) Vokabeldateien befinden sich im Ordner ...\Data\Idx\ unter den persönlichen Dateien. Indizes haben die Dateiendung .idx.